设为首页 收藏本站 662p开源网
开启辅助访问 切换到宽版

QQ登录

只需一步,快速开始

新浪微博登陆

只需一步, 快速开始

切换风格 立即注册 找回密码

安卓教程网

发表于 2018-4-27 15:40:46 | 显示全部楼层 |阅读模式
更多
最近升级android studio到版本3.0.1后,想要使用FragmentActivity这个类,导入v4包,发现R文件报错了,也就是找不到的意思。
  如图:导包
此时选中v4包导进去。


确定之后它一下子就跑到这里来,这是Values文件。查看了一下,还真没有R文件的相关内容。

再看下build.gradle,已经显示报错了,本人第一次导入的时候没有报这个错,但四处修改bug之后,再重新导入时它就变成这样,不管删除还是怎样都报错。

看了一个compileSdkVersion 和targetSdkVersion,它们是一样的(如果不一样,一点要修改成一致);


在implementation 'com.android.support:support-v4:28.0.0-alpha1'前面加上annotationProcessor,没报错了。

但R文件还是没有找到。

最后我只能将28改为26,然后再clean Project问题就解决了,此时我就可以使用FragmentActivity了。


发表于 2018-4-27 15:42:28 | 显示全部楼层
支持支持再支持

新浪微博达人勋

注册会员

60

积分

20

威望

0

金钱

Rank: 2

积分
60
发表于 2018-5-19 14:57:52 | 显示全部楼层
关注一下先

新浪微博达人勋

注册会员

144

积分

42

威望

7

金钱

Rank: 2

积分
144
发表于 2018-5-22 01:55:08 | 显示全部楼层
没人回帖。。。我来个吧
您需要登录后才可以回帖 登录 | 立即注册 新浪微博登陆

本版积分规则

Archiver|手机版|小黑屋|安卓教程网 ( 粤ICP备12089784号  

GMT+8, 2018-8-21 14:37 , Processed in 1.257608 second(s), 46 queries .

Powered by Discuz X3.1

© 2001-2013 IOS教程网

快速回复 返回顶部 返回列表